OneinStack 1.3 发布,一键 PHP/JAVA 安装工具

    这个脚本是使用 shell编写,为了快速在生产环境上部署lnmp/lamp/lnmpa/lnmt(Linux、Nginx/Tengine/OpenResty、 MySQL/MariaDB/Percona、PHP、Apache、Tomcat),适用于CentOS 5~7(包括redhat)、Debian 6~8、Ubuntu 12~16的32位和64位。

    可根据需求自由组合以下:

    • lnmp(Linux + Nginx+ MySQL+ PHP)
    • lamp(Linux + Apache+ MySQL+ PHP)
    • lnmpa(Linux + Nginx+ MySQL+ PHP+ Apache):Nginx处理静态,Apache(mod_php)处理动态PHP
    • lnmt(Linux + Nginx+ MySQL+ Tomcat):Nginx处理静态,Tomcat(JDK)处理JAVA
    • lnmh(Linux + Nginx+ MySQL+ HHVM)

    V1.3版本更新如下:

    • 增加OpenResty
    • 增加SS-libev
    • php编译增加--with-config-file-scan-dir参数,简化php扩展模块载入方式
    • 修复Ubuntu 16.04下PHP-5.3编译失败
    • 源码更新至最新稳定版本

    OneinStack特性:

    • 持续不断更新
    • 源码编译安装,大多数源码是最新stable版,并从官方网址下载
    • 提供多个数据库版本(MySQL-5.7, MySQL-5.6, MySQL-5.5, MariaDB-10.1, MariaDB-10.0, MariaDB-5.5, Percona-5.7,Percona-5.6, Percona-5.5)
    • 提供多个PHP版本(php-5.3, php-5.4, php-5.5,php-5.6,php-7)
    • 提供Nginx、Tengine、OpenResty
    • 提供多个Apache版本(Apache-2.4,Apache-2.2)
    • 提供多个Tomcat版本(Tomcat-8,Tomcat-7)
    • 提供多个JDK版本(JDK-1.8,JDK-1.7,JDK-1.6)
    • 根据自己需求安装PHP缓存加速器,提供ZendOPcache、xcache、apcu、eAccelerator。及php加解密工具ionCube、ZendGuardLoader
    • 根据自己需求安装Pureftpd、phpMyAdmin
    • 根据自己需求安装Memcached、Redis
    • 根据自己需求可使用tcmalloc或者jemalloc优化MySQL、Nginx
    • 提供添加虚拟主机脚本
    • 提供Nginx/Tengine/OpenResty、PHP、Redis、phpMyAdmin升级脚本
    • 提供本地备份和远程备份(服务器之间rsync)脚本
    • 提供CentOS 6、7下HHVM安装

    更多信息请访问官网:https://oneinstack.com/

    OneinStack 1.3 发布,一键 PHP/JAVA 安装工具

    Fri Apr 29 09:31:17 CST 2016

    • 本文由 发表于 2016-04-29
    • 转载请务必保留本文链接:https://linuxeye.com/446.html
    OneinStack自动部署Let's Encrypt证书 OneinStack

    OneinStack自动部署Let’s Encrypt证书

    Let's Encrypt是一个由电子前哨基金会、Mozilla基金会、Akamai、密歇根大学、思科联合发起的一个项目。它旨在为站长提供一个免费的、完全自动化的证书申请过程,从而让整个互联网都能享受...
    OneinStack PHP多版本共存教程 Linux

    OneinStack PHP多版本共存教程

    教程基于《OneinStack》一键PHP/JAVA安装工具中lnmp模式,很用户希望一个网站运行在php5.4,另一个网站运行在php7.0下,一台服务器上同时支持多个PHP版本,步骤如下: 1. ...
    匿名

    发表评论

    匿名网友

      • 深蓝 深蓝

        我前天才装的1.2,今天就看到1.3了,情何以堪。。。

        • 淡茶 淡茶

          要是在配个管理面板就好了!!!

          • 老司机 老司机

            我能搭建成功WordPress,全靠您这个一体包。

            • lighthouse lighthouse

              包中nginx 是1.1版的 ,版本太低,希望更新一下

                • yeho yeho

                  @ lighthouse 是最新的1.10.0,你看错了吧?

                    • lighthouse lighthouse

                      @ yeho 实在不好意思,确实是看错了

                  • reizhi reizhi

                    报错 mysql-5.6.30-linux-glibc2.5-i686.tar.gz download failed, Please contact the author!

                    • lfcjava lfcjava

                      nginx+tomcat+redis,如何确定tomcat已正常启动,tomcat的页面能否直接访问吗,如输入 IP :端口号!

                        • yeho yeho

                          @ lfcjava 随便丢一个index.jsp放到网站根目录(/data/wwwroot/绑定域名/) 重启tomcat,看日志/usr/local/tomcat/logs/catalina.out

                        • 第十一颗行星 第十一颗行星

                          源码编译确实很好,不过说真的,确实太耗时了

                          • 采觅博主 采觅博主

                            为啥1.4版本还没发布更新信息的文章,是不是因为很多地方还在修改完善 :grin:

                              • yeho yeho

                                @ 采觅博主 这个更新信息没发布到博客,不影响使用

                                  • 采觅博主 采觅博主

                                    @ yeho 我是看到你的镜像库里面oneinstack文件日期更新过了是9月的,V1.4是7月的,所以好奇。
                                    话说oneinstack新版本什么时候来呀,按你原先的更新历史,这次算是断更一个月了 :grin:

                                • 菊部 菊部

                                  绝壁支持

                                  • 网站设计 网站设计

                                    很好!

                                    • 欧耶 欧耶

                                      安装了下 oneinstack ,功能很强大,过几天做几个站,说说发现的问题
                                      第一 jemalloc 最新版到 4.3.1 了 希望博主更新下 安装的时候 xsltproc 这个可以通过apt-get 装一下,因为默认没有安装,虽然不知道能不能用得上
                                      第二 MYSQL 5.6 Warning: Using a password on the command line interface can be insecure.
                                      命令设置密码警告,希望可以参照lnmp 换一个设定方式,因为有时候会因为这样无法启动 mysql,我用其他脚本碰到过
                                      第三 WARNING: can’t open config file: /root/oneinstack/src/nginx-1.10.2/../openssl-1.0.2j/.openssl/ssl/openssl.cnf 在log 里看到不知道什么什么鬼,不过我安装其他脚本的时候也发现过这个警告,结论是会对 ssl 有影响
                                      第四安装后 能不能 把用的几个脚本留下 其他的加个清理空间的命令都清理掉
                                      我用的是 atlantic ubuntu14.04 -32 测试的
                                      很感谢你开发的脚本,一点小建议,等以后用的多了再反馈

                                        • yeho yeho

                                          @ 欧耶 1. jemalloc已经更新、xsltproc好像用不到
                                          2. 这个是警告,可以忽略
                                          3. 是否安装失败?
                                          4. 安装后可以删除src目录里面源码即可

                                        • 无忧精品教程 无忧精品教程

                                          请问如果一开始装的时候没有安装FTP,后续应该怎么安装FTP。

                                          • Fox Fox

                                            能不能有个稳定的版本?服务器求稳,安全!毕竟有些还用这1.1 1.2等!除非有重大漏洞,来个补丁升级!
                                            看@老司机 回复的!毕竟也有很多不懂linux(也包括我),一年一个版本也行,或者半年也行,更新太频繁了!
                                            就怕更新了,出现太多问题,自己又没办法解决,网站又瘫了!

                                              • yeho yeho

                                                @ Fox 我自己有强迫症,一般稳定不用管,忽略吧,没关系的,一般大功能才能写changlog

                                                  • Fox Fox

                                                    @ yeho 看mirrors里面 有个lnmp-full.tar.gz
                                                    这个跟oneinstack-full.tar.gz 有啥区别不?

                                                      • yeho yeho

                                                        @ Fox lnmp-full.tar.gz 不带java,oneinstack-full.tar.gz带java,优先更新

                                                  • youran youran

                                                    安装好了phpmyadmin怎么访问呢

                                                      • yeho yeho

                                                        @ youran 浏览器访问服务器公网ip,或者直接http://public_ip/phpMyAdmin

                                                      • linuxprober linuxprober

                                                        linuxeye is good … 运维笔记做的不错

                                                        • helsing helsing

                                                          腾讯云加了腾讯免费 SSL,安装了 FTP,但是 FTP 账号用 FZ 软件无法登陆,只能 root 账号登陆,TCP 22端口已经开放设置好了的。在腾讯云倒是没这个问题,很奇怪呢?求解,谢谢。:)